Minecraft 1.13 is just around the corner, but there are a LOT of changes that you need to be aware of as a responsible Minecraft community owner before upgrading.

If you'd rather read directly from the source, see md_5's post on Spigot's website regarding the availability of Spigot 1.13-pre7 (click here).

Is Spigot for 1.13 available?

Yes, there are development builds of Spigot 1.13 available, but you should use extreme caution when switching over as there are many breaking changes that can cause world corruption, plugin incompatibilities, and server crashes. Please read md_5's full post to understand the scope of this update and what has been changed.

Will my plugins work upon upgrade?

Probably not. At least, it's not very likely that they all will.

Here are important changes that are taking place with the Bukkit API that will affect most common and popular plugins, if they aren't already prepared:

  • Block IDs have been removed.
  • Block data values are deprecated (may be removed in the future!)
  • Art API: Two paintings have been renamed to bring them inline with vanilla.
  • Particles: FOOTSTEP & ITEM_TAKE were removed.
  • Materials API: Various renames to bring them in-line with vanilla. 

This list may not be complete; it may be possible for various other API changes to break compatibility with older plugins.

Please note: You should be upgrading your plugins before upgrading to 1.13, or at least preparing them prior to the upgrade.

Will my world be fine if I upgrade?

If you answer yes to all of the following conditions, your world may operate just fine upon upgrade. If you're upgrading to the 1.13 or newer dev builds, always take a backup! We take (minimum) once-daily backups for up to 10 days.

  1. Is your world's level-type something other than CUSTOMIZED?
  2. Have all your plugins that directly interact with the world updated for 1.13?

If you've answered yes to all of the above, you'll be fine with upgrading your world. If you've answered no to any one or more of the questions above, do not upgrade. Your world is likely not compatible with 1.13.

Do you recommend this in production?

As always, it's important to use caution with any third party software after a major Minecraft update and 1.13 is no exception. These early builds of Spigot 1.13 are primarily for plugin developers and not server owners, so we do not recommend running them on your production/live server. If data integrity of the current world is not important to you or your players, there may be no problems with upgrading.

A plugin isn't updated for 1.13. Can you fix it?

Unfortunately, we are unable to provide a copy of any specific plugin compatible with 1.13; this is up to the developer(s) of any given plugin.

Notes from Spigot's website

The current recommendation is to not retain data from 1.12.2 or earlier versions, as it may cause corruption of your server's world in a way that may not be immediately visible to you or your players. Testing the upgrade from 1.12.2 is definitely helpful, and if an issue with the world is found upon upgrade, will assist with eliminating any potential issues with future server upgrade by other users.

The Bukkit / Plugin API may change between 1.13 dev builds and newer versions. Various plugins may break because of changes introduced to the API.

Did this answer your question?