Right now, your server is likely running a Java version below 11, which is no longer supported by Paper. With Minecraft 1.17+, Java 16 is now required! You might see something like this in your server console until you update:
[io.papermc.paper.util.PaperJvmChecker] * WARNING - YOU ARE RUNNING AN OUTDATED VERSION OF JAVA.



If I don't update the Java version, will it break my server?

Currently, you should only need to update to Java 16 if you plan to run Paper for 1.17+.



How do I update the Java version on my server?

You can find this setting under ADVANCED in Prisma! From this dropdown, select JAVA SETTINGS then select the Java version you wish to run. Don't forget to save and restart!

Can one of my server admins do this?

Yes! Server admins in Prisma have access to this setting.


What Java versions does CubedHost support?

Our servers support the following versions of Java: 7, 8, 9, 11, 13, 14, 15, 16, 17

How do I know which Java version to use?

If you're not sure what version to use, your best bet is to go based on the version of Minecraft you're trying to run, whether vanilla or otherwise.

  • Minecraft version 1.17 requires Java 16

  • Minecraft versions 1.12 - 1.16 require Java 8

  • Minecraft versions 1.6 - 1.12 require Java 7

Some versions from 1.10-1.16 may be able to use more recent Java versions.


How do I get more help?

You can reach out to our team at any time using the blue bubble in the bottom-right of our site or by emailing us at [email protected].

Did this answer your question?